Current time: 11-22-2019, 11:57 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
WEIRD results
05-19-2016, 02:16 AM
Post: #1
Question WEIRD results
Really weird test results - found here: http://www.webpagetest.org/result/160518_AX_16QQ/

My website is alternating between 20 seconds to load, and less than 1 second. No idea why. Can anyone tell from these results what might be going on? There is no middle ground - either 20 seconds to load, or 1.

internally (on our LAN) the site is NEVER slow - it runs blazing fast every time.

Any ideas?
Find all posts by this user
Quote this message in a reply
05-21-2016, 01:19 AM
Post: #2
RE: WEIRD results
Hi MrJesse34,
could you share with us the same test but with tcpdump enabled to check how net is working?

Thanks
Find all posts by this user
Quote this message in a reply
05-21-2016, 01:26 AM
Post: #3
RE: WEIRD results
It turns out this was a three pronged problem. We figured it out. Here was the solution:

We had two A records setup for our domain - one as the primary and one as the failover. TTL was set to 5 min. The problem was, the registrar of the domain (register.com) cannot do anything other than random A record passing out. No round robin, no failover, etc. So basically, users were getting either our primary IP or our failover IP, both being hosted by different ISP companies.

The failover ISP was having an issue. They did work on the circuit over the weekend that caused a problem with our modem. A simple modem reboot fixed this.

Then, we found that there was a network error too. The network error had the failover IP natted wrong in our firewall. This was fixed.

Basically, it was a perfect storm.

So we also took off our secondary A record on register.com for now. Isntead, we want all users using our primary ISP which is lightning fast and much more reliable than our failover.

Finally, we're looking into dynamic DNS to handle our failover PROPERLY out in the world, so people who use our websites do not see any downtime.

Hope this helps someone else,

- Jesse
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)