Current time: 12-13-2019, 11:50 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ffmpeg Installed with --enable-libx264
06-04-2016, 09:47 AM
Post: #1
ffmpeg Installed with --enable-libx264
How to fix this error I see on the install page?

ffmpeg Installed with --enable-libx264 (required for video): NO

I am on windows 2008 and have ffmpeg in my path.
Find all posts by this user
Quote this message in a reply
09-27-2016, 02:35 PM (This post was last modified: 09-28-2016 02:20 AM by deshawnbw.)
Post: #2
RE: ffmpeg Installed with --enable-libx264
Hello,

I had a similar issue. For me, ffmpeg was in my path but not in the apache users path. That's the user that the apache process is running under. You can find the user via `ps aux | grep httpd` or `ps aux | grep apache2`.

You can confirm that ffmpeg is missing from the apache users path via printing the path via php:

exec("echo \$PATH;", $output);
print_r($output);
exit;

I needed to add the directory in which ffmpeg resides (`which ffmpeg`) into to the PATH of the apache user.

Also, that user should have permissions to execute ffmpeg.

hope this helps!

- DeShawn
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)