Current time: 11-22-2019, 09:22 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
TTFB Very Slow
06-25-2016, 06:18 PM
Post: #1
TTFB Very Slow
Looking for some advice or help on this problem.

Request #1 taking 5432ms to load. It's on a reseller VPS with A2hosting. Another site on the same server (both WP) loads in 1.6 secs. One difference is the slow loading site is running a GoDaddy SSL.

I have had a couple of techs try to help, but they are stumped. The site URL is https://members.artmarketingnews.com

Here's a report on what's been reviewed to date.

Tech's Overall Observations

Hosting account is good as you have A2’s Progress Reseller plan (the middle of the road plan) which is loads better than shared hosting.

Content Delivery Network (CDN) like CloudFlare is in place and functioning correctly.

Caching is being handled by the Better WordPress Minify plugin.

Images are optimized.

Home page specific

The content on your home page is very light which is good.

You’re not using the home page as a blog page, so there’s no excerpts to load, only minimal content and a few images. Those images look to be optimized.

There’s no sharing widgets on the home page or the sidebar, only course login.

The force HTTPS plugin was deleted and the extraneous force https code removed from the .htaccess file.

There are no inactive plugins on the site to remove.

Database optimization is being handled by the Optimize Database after Deleting Revisions plugin.

.htaccess has scraping protection, image expiration, and XML-RPC blocking

I removed the additional HTTP redirect in the .htaccess file then flushed the CloudFlare cache and ran speed tests on Web Pulse and GTMetrix. The page load time increase was minimal, so I added the HTTP redirect code back to the .htaccess file.

I then reset the .htaccess file and re-saved your site's permalinks then flushed the CloudFlare cache and ran speed tests on Web Pulse and GTMetrix. There was no change in the test results, so I returned the .htaccess to its original state.

Thinking I may have made too many changes to the .htaccess and permalinks at once, I waited 24 hours and repeated the steps above. No change. I then waited another 24 hours and repeated the steps, flushing the CloudFlare cache too. No change.

I then looked through at the files in your public_html directly on your web hosting plan to see if there were any extra files, possibly from a previous web host but didn't find anything. I also checked for extra files in your Genesis child theme and errors in the style.css. I didn't find anything out of place.

Additionally, I looked over all the settings on the BWP Minify plugin and didn't see any issues. Since I don't work with BWP Minify a lot (I use W3 Total Cache), I searched the Internet for any known issues but didn't find anything that pertained to your situation.

Lastly, I checked all of your CloudFlare settings and made sure to perform cache flushes before and after the items above to make sure I was working with a clean baseline for testing.

I am grateful in advance for any suggestions or help. Thank you!
Find all posts by this user
Quote this message in a reply
06-30-2016, 01:36 PM
Post: #2
RE: TTFB Very Slow
Have you tried using a profiler to determine which plugin is slowing you down?
Find all posts by this user
Quote this message in a reply
07-04-2016, 11:23 AM
Post: #3
RE: TTFB Very Slow
(06-30-2016 01:36 PM)alanvo Wrote:  Have you tried using a profiler to determine which plugin is slowing you down?

Thanks for the suggestion. It's not a plugin. It's the GET on the SSL.
Find all posts by this user
Quote this message in a reply
07-04-2016, 05:28 PM
Post: #4
RE: TTFB Very Slow
A long TTFB in WordPress is usually caused by a slow hosting environment and or a plugin/theme. This is mostly the backend processing time where the browser waits for WordPress to compile the page from the database and the hundreds of PHP files included in plugins, themes etc. The SSL connection handshake is only taking about .1s here.

My beat is it's the minify plugin. Try installing and running the WordPress P3 profiler plugin to identify the problem plugin or manually deactivate each plugin until you notice the site speed improving. If it's still an issue try switching to the default WordPress theme.

To help troubleshoot the issue you should pause or remove Cloudflare as this can add a second or two to the TTFB.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)