Current time: 03-27-2017, 04:48 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Private Instance - Chrome - URL not loading when triggered with proxy
03-02-2017, 08:37 AM (This post was last modified: 03-02-2017 08:39 AM by vijay_nts.)
Post: #1
Private Instance - Chrome - URL not loading when triggered with proxy
Hi

I am trying to invoke chrome with proxy. Earlier versions worked fine with the below command.

options='--load-extension="%WPTDIR%\extension" --proxy-pac-url="file://c:/Proxy/accelerated_pac_base.pac" --user-data-dir="%PROFILE%"'

But after updating the chrome and WPT, it is not working. Outside the network without proxy, it is working fine.
Please let me know, If I am missing something.
Find all posts by this user
Quote this message in a reply
03-03-2017, 06:36 AM
Post: #2
RE: Private Instance - Chrome - URL not loading when triggered with proxy
Try putting just the --proxy-pac-url option into a "command-line" setting. i.e:

command-line='--proxy-pac-url="file://c:/Proxy/accelerated_pac_base.pac"'

The options= setting was killed because it was too easy to break the user-data-dir and extension stuff, both of which aren't optional.
Visit this user's website Find all posts by this user
Quote this message in a reply
03-03-2017, 07:06 AM (This post was last modified: 03-03-2017 07:34 AM by vijay_nts.)
Post: #3
RE: Private Instance - Chrome - URL not loading when triggered with proxy
(03-03-2017 06:36 AM)pmeenan Wrote:  Try putting just the --proxy-pac-url option into a "command-line" setting. i.e:

command-line='--proxy-pac-url="file://c:/Proxy/accelerated_pac_base.pac"'

The options= setting was killed because it was too easy to break the user-data-dir and extension stuff, both of which aren't optional.

Thanks Patrick..Now I am getting Failed to load extension from C:\Program Files (x86)\Google\Chrome SxS\Applications\56.0.2924.87\%WPTDIR%\extension. Manifest file is missing or unreadable

(03-03-2017 07:06 AM)vijay_nts Wrote:  
(03-03-2017 06:36 AM)pmeenan Wrote:  Try putting just the --proxy-pac-url option into a "command-line" setting. i.e:

command-line='--proxy-pac-url="file://c:/Proxy/accelerated_pac_base.pac"'

The options= setting was killed because it was too easy to break the user-data-dir and extension stuff, both of which aren't optional.

Thanks Patrick..Now I am getting Failed to load extension from C:\Program Files (x86)\Google\Chrome SxS\Applications\56.0.2924.87\%WPTDIR%\extension. Manifest file is missing or unreadable

Thanks Patrick..Now it is working fine. Thank You for your support.
Find all posts by this user
Quote this message in a reply
03-23-2017, 01:24 AM
Post: #4
RE: Private Instance - Chrome - URL not loading when triggered with proxy
What was the exact resolution to get this working?

When I use the Chrome command line from the web under Advanced Settings:
--proxy-pac-url=file:///C:/webpagetest/config.pac

This works as expected. Any attempt to add this to the wptdriver.ini does not work. Oddly it opens a number of tabs where it appears to be getting script commands. However, the commands are getting treated as URLs.

wptdriver.ini
command-line='--proxy-pac-url="file:///C:/webpagetest/config.pac"'

My goal is to have this as default and not have to enter it for each test through the web ui.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)