Current time: 05-21-2018, 05:44 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Enabling SSL on Private instance
04-15-2017, 04:36 AM
Post: #1
Enabling SSL on Private instance
Hi,

are there any instructions to setup SSL on the Private instance? Basically i want to add SSL(https) for my webpagetest server. Is is a simple config change with certificate installation? . Also does the current agents support ssl authentication with webpagetest server ?

Thanks
Saikumar
Find all posts by this user
Quote this message in a reply
04-16-2017, 02:40 PM
Post: #2
RE: Enabling SSL on Private instance
I'm using HTTPS on my private WebPageTest instance. There was a problem with older EC2 test agent images, but current ones should be ok.
Visit this user's website Find all posts by this user
Quote this message in a reply
04-18-2017, 05:03 AM (This post was last modified: 04-18-2017 05:04 AM by snvssaikumar.)
Post: #3
RE: Enabling SSL on Private instance
(04-16-2017 02:40 PM)josephscott Wrote:  I'm using HTTPS on my private WebPageTest instance. There was a problem with older EC2 test agent images, but current ones should be ok.

Hi,

do you have steps to follow for enabling https ? i am taking care of certificate creation and installation. i am look for list of changes in code/agents config

Thanks
Saikumar
Find all posts by this user
Quote this message in a reply
01-11-2018, 06:17 AM
Post: #4
RE: Enabling SSL on Private instance
(04-18-2017 05:03 AM)snvssaikumar Wrote:  do you have steps to follow for enabling https ? i am taking care of certificate creation and installation. i am look for list of changes in code/agents config

I came across this thread when searching for an answer to the same question. It looks like /var/www/webpagetest/www/nginx.conf is port agnostic. I was able to follow the basic guidelines here to enable SSL simply by editing /etc/nginx/sites-available/default. See section A single HTTP/HTTPS server.

Here's an example:
Code:
server {
    server_name myservername.org;
    listen 80 default_server;
    listen 443 ssl default_server;
    listen [::]:80 default_server ipv6only=on;
    listen [::]:443 default_server ssl ipv6only=on;
    ssl_certificate /path/to/myservername.org.crt;
    ssl_certificate_key /path/to/myservername.org.key;
Find all posts by this user
Quote this message in a reply
02-09-2018, 06:41 AM
Post: #5
RE: Enabling SSL on Private instance
Remember if you're following one of the many tutorials for this online, they will only talk about opening port 80 at AWS level.

If you're going HTTPS you'll need to open port 443. That one just caught me out.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)