Current time: 07-18-2019, 11:16 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Need some advice on my site.
06-17-2017, 09:29 AM (This post was last modified: 06-17-2017 09:30 AM by rosswaters.)
Post: #9
RE: Need some advice on my site.
I am looking at it all but I did just want to say there is a issue with the SSL. It is our number one complaint from our users and they all say the same thing, I can get on your site with my desktop but not my older iPad.

I did find by testing some of the above answers I got that my server is also the issue and if I want to fix it and not move into something expensive I need to break my site apart into sub-folders and install the membership stuff in an isolated install. I can't afford all the cost that go into a VPS or a dedicated server at the moment. Even if I went with Linode I would have to fall in the 20 a month package and it would only be a year or less before I would need more storage. On top of that I feel I would have to hire or find someone that could do the server side securing plus the network stuff because I doubt I could do that on top of what I have to do every month just to make what I am doing work.

Everyone has given valid points and that is why I asked the questions in the first place. I know fixing the SSL will not resolve the issues I am having with speed but it will fix a few of my headaches with the emails I get weekly because of my SSL. I am trying currently to see if Comondo will resolve the issue as I bought the SSL from them.

As of now I am going to re-structure the site to lighten the quires on the front end so the site is faster over all for people browsing the site and deciding if they want to join. After that users will log into the site where the membership is at and with that they will have to deal with a little slower performance until I have the funds to move to something better.

My new page I built in a subdomain and tested performs night and day over the current root domain. By utilizing lazy loading and a few other things from what others have said the new mock up home page loads in 1.12 seconds is a grade A at 87% faster than other tested sites. It does this without having My CDN connected. My biggest gains were lowering my queries the server has to perform. I went from 89Qs to 38Qs just in testing this method out. The membership side will still be a little slow but for now I think I at least have plans to move forward.

I thank you and everyone that responded as it lead me to my next best option.

Ross

(06-17-2017 09:02 AM)GreenGecko Wrote:  OK, you go ahead and centre your efforts on improving ssl. By doing that, you totally ignore the fact that, using the WPT waterfall I provided for you, it adds under half a second to your initial page load, whereas there's 3.8 seconds of server side processing to be addressed: 8 times the delay.

Sure, it makes a difference, but no, it really shouldn't be your top priority.

( Same with the preload stuff: it will make stuff all difference to your TTFB, as it relates to resources loaded after the initial html skeleton )
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
Need some advice on my site. - rosswaters - 06-09-2017, 02:26 AM
RE: Need some advice on my site. - dfavor - 06-10-2017, 08:24 AM
RE: Need some advice on my site. - rosswaters - 06-17-2017 09:29 AM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)