Current time: 10-22-2018, 12:24 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
S3 archiving with private server
07-12-2018, 01:55 AM (This post was last modified: 07-12-2018 01:59 AM by wpt2018.)
Post: #1
S3 archiving with private server
Hello,

We followed the S3 archiving steps by filling the required settings (please see below)
archive_s3_server=s3.amazonaws.com
archive_s3_key=my-key
archive_s3_secret=my-secret
archive_s3_bucket=my-archive-bucket
archive_days=0

For some reason, we don't see the test results in the S3 bucket even though the AWS key have the proper permissions and confirmed that by running aws s3 cp command and setting the keys on the WPT server.

Some other info:
The EC2 instances and S3 live in the us-east-1 region.
We didn't set lasyArchive in the settings.ini file
No logs were written to: /var/www/webpagetest/www/log
The agents completed the tests execution successfully.

Is there anything else we can try to solve this issue? Like turn on debug logging, etc..
Find all posts by this user
Quote this message in a reply
07-13-2018, 02:07 AM
Post: #2
RE: S3 archiving with private server
The settings.ini file looks similar to mine. I'm not sure if this is the issue, but my setup uses an archiving cron job with the following curl command:

curl -sS http://localhost/cli/archive.php.

This then archives results to the S3 bucket per the settings.ini.
Find all posts by this user
Quote this message in a reply
07-14-2018, 09:47 AM
Post: #3
RE: S3 archiving with private server
(07-13-2018 02:07 AM)natedelgado Wrote:  The settings.ini file looks similar to mine. I'm not sure if this is the issue, but my setup uses an archiving cron job with the following curl command:

curl -sS http://localhost/cli/archive.php.

This then archives results to the S3 bucket per the settings.ini.

Thanks for you answer natedelgado. We want the test to be immediately archived after it completes. As far as I know archive cli is not needed since lasyArchive is not set.

I can give this a try if you can share the cron job setup steps.
Find all posts by this user
Quote this message in a reply
07-21-2018, 08:20 AM
Post: #4
RE: S3 archiving with private server
Finally made it working by adding below to the settings.ini since we are protecting our instance inbound traffic:
local_server=http://127.0.0.1
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)