Current time: 11-22-2018, 02:16 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2 same resources are being loaded 2 times?
10-24-2018, 02:55 AM
Post: #1
2 same resources are being loaded 2 times?
Hi,

Not sure if I titled the thread correctly.

test result : here

In "requests details" table

#1 and #20 are the same thing, why it's being loaded 2 times, no idea. Huh

let me know if I should be explaining it in more better way.

I want the #20 to be gone, how do I resolved this. please help me. Sad
Find all posts by this user
Quote this message in a reply
10-24-2018, 10:22 PM
Post: #2
RE: 2 same resources are being loaded 2 times?
My guess is your image lazyloader (or something similar) is loading an image tag that wither didn't have a URL or where it wasn't built correctly.

The "Initiated by" appears to point to the css that runs after the html content is loaded and runs a fade-in transition of some kind.

The request details look like a request for an image (accept headers):

Code:
:path: /
accept-language: en-US,en;q=0.9
accept-encoding: gzip, deflate, br
accept: image/webp,image/apng,image/*,*/*;q=0.8
user-agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.67 Safari/537.36 PTST/181019.181040
:scheme: https
cookie: __cfduid=d7ed126cce53732342e707ecc5f4675051540313280
:method: GET
if-none-match: W/"8f91-578e7e3a60473"
referer: https://www.seoagencymumbai.com/
:authority: www.seoagencymumbai.com

Since it is getting loaded by css, my guess would be for a background image for an element somewhere on the page.

In searching through the source, there are a few "background-image:url();" styles on div elements which would cause it. If there is no image you can't just pass an empty url, it will default to relative to the page and try to re-load the html as an image.
Visit this user's website Find all posts by this user
Quote this message in a reply
10-25-2018, 09:24 AM
Post: #3
RE: 2 same resources are being loaded 2 times?
Likely reason...

1) Request #20 really is some sort of versioned link or AJAX link.

A link which includes query parameters (?voo=doo).

2) You're running some sort of poorly conceived plugin which strips off query parameters to speed up caching.

Super bad idea. This will surely speed up your site also break your site in ways which are near impossible to debug.

Fix: Flush your caches. Disable your caching plugin. Retest.

If this fixes your site, then find another, more well conceived caching plugin to use.

Like help speeding up your site? Skype me @ ID davidfavor for a quote. Be sure to include your site name in your Skype Add Contact request.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)