Current time: 11-13-2019, 06:35 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Docker Private WPT Instance - Test Never Finishes [logs included]
04-23-2019, 12:46 AM
Post: #1
Docker Private WPT Instance - Test Never Finishes [logs included]
So I have setup Docker WPT agent and server running on my Windows 10 desktop via PowerShell:

Code:
C:\Users\mydirectory\dockerfiles> docker ps
CONTAINER ID        IMAGE               COMMAND                  CREATED             STATUS              PORTS                           NAMES
f2d89f9d156f        webpagetest/agent   "/bin/bash /wptage..."   4 minutes ago       Up 4 minutes                                        jolly_sinoussi
1f6b0f605519        local-wptserver     "docker-php-entryp..."   20 minutes ago      Up 20 minutes       443/tcp, 0.0.0.0:4000->80/tcp   objective_euler

and can see the agent listed in the Install path:

Code:
WebPageTest 18.10 Installation Check
PHP
PHP version at least 5.3: 5.6.40
GD module installed: yes
FreeType enabled for GD (required for video rendering): yes
zip module installed: yes
zlib module installed: yes
mbstring available: yes
curl module installed: yes
php.ini allow_url_fopen enabled: yes
APC installed: NO (optional)
SQLite installed (for editable test labels): yes
Open SSL module installed (for "Login with Google"): yes
xml module installed (for RSS feeds): yes
pcre module installed (for RSS feeds): yes
xmlreader module installed (for RSS feeds): yes
php.ini upload_max_filesize > 10MB: 20M
php.ini post_max_size > 10MB: 20M
php.ini memory_limit > 256MB or -1 (disabled): 512M
System Utilities
ffmpeg installed with --enable-libx264 (required for video): yes
ffmpeg installed with scale and decimate filters (required for mobile video): 3.2.12-1~deb9u1,scale,mpdecimate
imagemagick compare installed (required for mobile video): yes
jpegtran installed (required for JPEG analysis): yes
exiftool installed (required for JPEG analysis): yes
Misc.
Python 2.7 with modules (faster mobile-video processing): Missing Python modules: SSIM (optional)
Filesystem
{docroot}/tmp writable: yes
{docroot}/dat writable: yes
{docroot}/results writable: yes
{docroot}/work/jobs writable: yes
{docroot}/logs writable: yes
{docroot}/tmp on tmpfs: NO (optional)
Test Locations
Test_loc : Test Location
Test : Test Location - 1 agents connected

However when I select the agent and run it, the test starts but never seems to finish, any idea what is going on here?

Output from the wptagent instance before / during the run:

Code:
C:\Users\mydirectory\dockerfiles> docker run --rm -p 4001:80 --network="host" -e "SERVER_URL=http://localhost:4000/work/" -e "LOCATION=Test" webpagetest/agent
Requirement already up-to-date: marionette_driver in /usr/local/lib/python2.7/dist-packages
Requirement already up-to-date: mozrunner>=7.4.0 in /usr/local/lib/python2.7/dist-packages (from marionette_driver)
Collecting six (from marionette_driver)
  Downloading https://files.pythonhosted.org/packages/73/fb/00a976f728d0d1fecfe898238ce23f502a721c0ac0ecfedb80e0d88c64e9/six-1.12.0-py2.py3-none-any.whl
Requirement already up-to-date: mozversion>=2.1.0 in /usr/local/lib/python2.7/dist-packages (from marionette_driver)
Requirement already up-to-date: mozfile>=1.2 in /usr/local/lib/python2.7/dist-packages (from mozrunner>=7.4.0->marionette_driver)
Requirement already up-to-date: mozlog~=4.0 in /usr/local/lib/python2.7/dist-packages (from mozrunner>=7.4.0->marionette_driver)
Requirement already up-to-date: mozinfo<2,>=0.7 in /usr/local/lib/python2.7/dist-packages (from mozrunner>=7.4.0->marionette_driver)
Requirement already up-to-date: mozprocess<2,>=0.23 in /usr/local/lib/python2.7/dist-packages (from mozrunner>=7.4.0->marionette_driver)
Requirement already up-to-date: mozdevice>=1.1.6 in /usr/local/lib/python2.7/dist-packages (from mozrunner>=7.4.0->marionette_driver)
Requirement already up-to-date: mozprofile~=2.1 in /usr/local/lib/python2.7/dist-packages (from mozrunner>=7.4.0->marionette_driver)
Requirement already up-to-date: mozterm in /usr/local/lib/python2.7/dist-packages (from mozlog~=4.0->mozrunner>=7.4.0->marionette_driver)
Requirement already up-to-date: blessings>=1.3 in /usr/local/lib/python2.7/dist-packages (from mozlog~=4.0->mozrunner>=7.4.0->marionette_driver)
Installing collected packages: six
  Found existing installation: six 1.11.0
    Not uninstalling six at /usr/lib/python2.7/dist-packages, outside environment /usr
Successfully installed six-1.12.0
/bin/sh: 1: git: not found
Python 2.7.15rc1
Modern traceroute for Linux, version 2.1.0
Copyright (c) 2016  Dmitry Butskoy,   License: GPL v2 or any later
RTNETLINK answers: Operation not permitted
Cannot find device "ifb0"
RTNETLINK answers: Operation not permitted
Cannot find device "ifb0"
bad action parsing
parse_action: bad value (5:mirred)!
Illegal "action"
Cannot find device "ifb0"
14:34:48.722 - Get Work Error: None
14:34:53.857 - Get Work Error: None
14:34:58.975 - Get Work Error: None
14:35:04.093 - Get Work Error: None
14:35:34.343 - Get Work Error: None
14:35:39.470 - Get Work Error: None
chrome: no process found
sudo: unable to resolve host moby
dnsmasq: unrecognized service
sudo: unable to resolve host moby
rndc: neither /etc/bind/rndc.conf nor /etc/bind/rndc.key was found
sudo: unable to resolve host moby
sudo: systemd-resolve: command not found
sudo: unable to resolve host moby
sudo: unable to resolve host moby
sudo: unable to resolve host moby
sudo: unable to resolve host moby
sudo: unable to resolve host moby
sudo: unable to resolve host moby
[73:73:0422/143545.902611:ERROR:browser_dm_token_storage_linux.cc(101)] Error: /etc/machine-id contains 0 characters (32 were expected).
[73:86:0422/143546.171517:ERROR:bus.cc(396)] Failed to connect to the bus: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
[73:174:0422/143546.248658:ERROR:bus.cc(396)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")

DevTools listening on ws://127.0.0.1:9222/devtools/browser/b50e3831-c7ef-44a6-890e-a90233cd0c01

(chrome:73): LIBDBUSMENU-GLIB-WARNING **: 14:35:46.369: Unable to get session bus: Unknown or unsupported transport ?disabled? for address ?disabled:?
sudo: unable to resolve host moby
Cannot find device "ifb0"
ffmpeg version 3.4.4-0ubuntu0.18.04.1 Copyright (c) 2000-2018 the FFmpeg developers
  built with gcc 7 (Ubuntu 7.3.0-16ubuntu3)
  configuration: --prefix=/usr --extra-version=0ubuntu0.18.04.1 --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu --incdir=/usr/include/x86_64-linux-gnu --enable-gpl --disable-stripping --enable-avresample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmp3lame --enable-libmysofa --enable-libopenjpeg --enable-libopenmpt --enable-libopus --enable-libpulse --enable-librubberband --enable-librsvg --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxml2 --enable-libxvid --enable-libzmq --enable-libzvbi --enable-omx --enable-openal --enable-opengl --enable-sdl2 --enable-libdc1394 --enable-libdrm --enable-libiec61883 --enable-chromaprint --enable-frei0r --enable-libopencv --enable-libx264 --enable-shared
  libavutil      55. 78.100 / 55. 78.100
  libavcodec     57.107.100 / 57.107.100
  libavformat    57. 83.100 / 57. 83.100
  libavdevice    57. 10.100 / 57. 10.100
  libavfilter     6.107.100 /  6.107.100
  libavresample   3.  7.  0 /  3.  7.  0
  libswscale      4.  8.100 /  4.  8.100
  libswresample   2.  9.100 /  2.  9.100
  libpostproc    54.  7.100 / 54.  7.100
[x11grab @ 0x5566df65e640] Stream #0: not enough frames to estimate rate; consider increasing probesize
Input #0, x11grab, from ':166095544':
  Duration: N/A, start: 1555943747.297504, bitrate: N/A
    Stream #0:0: Video: rawvideo (BGR[0] / 0x524742), bgr0, 1024x768, 10 fps, 1000k tbr, 1000k tbn, 1000k tbc
Stream mapping:
  Stream #0:0 -> #0:0 (rawvideo (native) -> h264 (libx264rgb))
Press [q] to stop, [?] for help
[libx264rgb @ 0x5566df66a280] using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX FMA3 BMI2 AVX2
[libx264rgb @ 0x5566df66a280] profile High 4:4:4 Predictive, level 3.1, 4:4:4 8-bit
[libx264rgb @ 0x5566df66a280] 264 - core 152 r2854 e9a5903 - H.264/MPEG-4 AVC codec - Copyleft 2003-2017 - http://www.videolan.org/x264.html - options: cabac=0 ref=1 deblock=0:0:0 analyse=0:0 me=dia subme=0 psy=0 mixed_ref=0 me_range=16 chroma_me=1 trellis=0 8x8dct=0 cqm=0 deadzone=21,11 fast_pskip=0 chroma_qp_offset=0 threads=3 lookahead_threads=1 sliced_threads=0 nr=0 decimate=1 interlaced=0 bluray_compat=0 constrained_intra=0 bframes=0 weightp=0 keyint=250 keyint_min=10 scenecut=0 intra_refresh=0 rc=cqp mbtree=0 qp=0
Output #0, mp4, to '/wptagent/work/moby/190422_YY_2.1.0/1_video.mp4':
  Metadata:
    encoder         : Lavf57.83.100
    Stream #0:0: Video: h264 (libx264rgb) (avc1 / 0x31637661), bgr0, 1024x768, q=-1--1, 10 fps, 10240 tbn, 10 tbc
    Metadata:
      encoder         : Lavc57.107.100 libx264rgb
    Side data:
      cpb: bitrate max/min/avg: 0/0/0 buffer size: 0 vbv_delay: -1
frame=   17 fps= 11 q=-1.0 Lsize=      80kB time=00:00:01.60 bitrate= 409.1kbits/s speed=1.06x
video:79kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 1.098385%
[libx264rgb @ 0x5566df66a280] frame I:1     Avg QP: 0.00  size: 23311
[libx264rgb @ 0x5566df66a280] frame P:16    Avg QP: 0.00  size:  3569
[libx264rgb @ 0x5566df66a280] mb I  I16..4: 100.0%  0.0%  0.0%
[libx264rgb @ 0x5566df66a280] mb P  I16..4: 92.6%  0.0%  0.0%  P16..4:  0.0%  0.0%  0.0%  0.0%  0.0%    skip: 7.4%
[libx264rgb @ 0x5566df66a280] coded y,u,v intra: 0.1% 0.1% 0.1% inter: 0.0% 0.0% 0.0%
[libx264rgb @ 0x5566df66a280] i16 v,h,dc,p: 100%  0%  0%  0%
[libx264rgb @ 0x5566df66a280] kb/s:378.42
Exiting normally, received signal 15.
ffmpeg: no process found
sudo: unable to resolve host moby
Cannot find device "ifb0"
ffmpeg version 3.4.4-0ubuntu0.18.04.1 Copyright (c) 2000-2018 the FFmpeg developers
  built with gcc 7 (Ubuntu 7.3.0-16ubuntu3)
  configuration: --prefix=/usr --extra-version=0ubuntu0.18.04.1 --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu --incdir=/usr/include/x86_64-linux-gnu --enable-gpl --disable-stripping --enable-avresample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmp3lame --enable-libmysofa --enable-libopenjpeg --enable-libopenmpt --enable-libopus --enable-libpulse --enable-librubberband --enable-librsvg --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxml2 --enable-libxvid --enable-libzmq --enable-libzvbi --enable-omx --enable-openal --enable-opengl --enable-sdl2 --enable-libdc1394 --enable-libdrm --enable-libiec61883 --enable-chromaprint --enable-frei0r --enable-libopencv --enable-libx264 --enable-shared
  libavutil      55. 78.100 / 55. 78.100
  libavcodec     57.107.100 / 57.107.100
  libavformat    57. 83.100 / 57. 83.100
  libavdevice    57. 10.100 / 57. 10.100
  libavfilter     6.107.100 /  6.107.100
  libavresample   3.  7.  0 /  3.  7.  0
  libswscale      4.  8.100 /  4.  8.100
  libswresample   2.  9.100 /  2.  9.100
  libpostproc    54.  7.100 / 54.  7.100
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/wptagent/work/moby/190422_YY_2.1.0/1_video.mp4':
  Metadata:
    major_brand     : isom
    minor_version   : 512
    compatible_brands: isomiso2avc1mp41
    encoder         : Lavf57.83.100
  Duration: 00:00:01.70, start: 0.000000, bitrate: 385 kb/s
    Stream #0:0(und): Video: h264 (High 4:4:4 Predictive) (avc1 / 0x31637661), gbrp(tv, gbr/unknown/unknown), 1024x768, 380 kb/s, 10 fps, 10 tbr, 10240 tbn, 20 tbc (default)
    Metadata:
      handler_name    : VideoHandler
Stream mapping:
  Stream #0:0 -> #0:0 (h264 (native) -> png (native))
Press [q] to stop, [?] for help
Output #0, image2, to '/wptagent/work/moby/190422_YY_2.1.0/video_1/viewport.png':
  Metadata:
    major_brand     : isom
    minor_version   : 512
    compatible_brands: isomiso2avc1mp41
    encoder         : Lavf57.83.100
    Stream #0:0(und): Video: png, rgb24, 1024x768, q=2-31, 200 kb/s, 10 fps, 10 tbn, 10 tbc (default)
    Metadata:
      handler_name    : VideoHandler
      encoder         : Lavc57.107.100 png
frame=    1 fps=0.0 q=-0.0 Lsize=N/A time=00:00:00.10 bitrate=N/A speed=3.74x
video:10kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: unknown
[73:92:0422/143549.645712:ERROR:zygote_communication_linux.cc(206)] Failed to send Reap message to zygote
[0422/143549.646033:ERROR:nacl_helper_linux.cc(310)] NaCl helper process running without a sandbox!
Most likely you need to configure your SUID sandbox correctly
[73:73:0422/143549.667872:ERROR:zygote_communication_linux.cc(276)] Failed to send GetTerminationStatus message to zygote
[73:73:0422/143549.674237:ERROR:zygote_communication_linux.cc(276)] Failed to send GetTerminationStatus message to zygote
[73:73:0422/143549.675710:ERROR:zygote_communication_linux.cc(276)] Failed to send GetTerminationStatus message to zygote
[73:73:0422/143549.679470:ERROR:zygote_communication_linux.cc(276)] Failed to send GetTerminationStatus message to zygote
[73:73:0422/143549.682462:ERROR:zygote_communication_linux.cc(276)] Failed to send GetTerminationStatus message to zygote
[375:375:0422/143549.742126:ERROR:sandbox_linux.cc(364)] InitializeSandbox() called with multiple threads in process gpu-process.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)